2 %global date %(date +%Y%m%d)
4 # If you are doing a git snapshot:
6 # Release should be 1%{git}%{?dist}
7 # Source0 should be notmuch-%{version}-%{git}.tar.gz
8 # git version is generated by 'git show-ref --hash=8 HEAD'
10 # To create a tarball:
12 # git clone git://notmuchmail.org/git/notmuch
14 # git archive --format=tar --prefix=notmuch-0.4/ HEAD | gzip > notmuch-0.4-`git show-ref --hash=8 HEAD`.tar.gz
20 Summary: Thread-based email index, search and tagging
22 Group: Applications/Internet
24 URL: https://notmuchmail.org/
26 Source0: https://notmuchmail.org/releases/notmuch-%{version}.tar.gz
28 BuildRequires: xapian-core-devel gmime-devel libtalloc-devel
29 BuildRequires: zlib-devel emacs-el emacs-nox python ruby ruby-devel perl
32 Fast system for indexing, searching, and tagging email. Even if you
33 receive 12000 messages per month or have on the order of millions of
34 messages that you've been saving for decades, Notmuch will be able to
35 quickly search all of it.
37 Notmuch is not much of an email program. It doesn't receive messages
38 (no POP or IMAP support). It doesn't send messages (no mail composer,
39 no network code at all). And for what it does do (email search) that
40 work is provided by an external library, Xapian. So if Notmuch
41 provides no user interface and Xapian does all the heavy lifting, then
42 what's left here? Not much.
45 Summary: Development libraries and header files for %{name}
46 Group: Development/Libraries
47 Requires: %{name} = %{version}-%{release}
50 The %{name}-devel package contains libraries and header files for
51 developing applications that use %{name}.
53 %package -n emacs-notmuch
54 Summary: Not much support for Emacs
55 Group: Applications/Editors
57 Requires: %{name} = %{version}-%{release}, emacs(bin) >= %{_emacs_version}
59 %description -n emacs-notmuch
62 %package -n python-notmuch
63 Summary: Python bindings for notmuch
64 Group: Development/Libraries
66 Requires: %{name} = %{version}-%{release}
68 %description -n python-notmuch
71 %package -n notmuch-ruby
72 Summary: Ruby bindings for notmuch
73 Group: Development/Libraries
74 Requires: %{name} = %{version}-%{release}
76 %description -n notmuch-ruby
80 Summary: Notmuch (of a) helper for Mutt
81 Group: Development/Libraries
83 Requires: %{name} = %{version}-%{release}
84 Requires: perl(Term::ReadLine::Gnu)
87 notmuch-mutt provide integration among the Mutt mail user agent and
88 the Notmuch mail indexer.
94 ./configure --prefix=%{_prefix} --libdir=%{_libdir} --sysconfdir=%{_sysconfdir} \
95 --mandir=%{_mandir} --includedir=%{_includedir} --emacslispdir=%{_emacs_sitelispdir}
96 make %{?_smp_mflags} CFLAGS="%{optflags}"
103 export CONFIGURE_ARGS="--with-cflags='%{optflags}'"
104 ruby extconf.rb --vendor
108 pushd contrib/notmuch-mutt
113 make install DESTDIR=%{buildroot}
115 pushd bindings/python
116 python setup.py install -O1 --skip-build --root %{buildroot}
120 make install DESTDIR=%{buildroot}
123 install contrib/notmuch-mutt/notmuch-mutt %{buildroot}%{_bindir}/notmuch-mutt
124 install contrib/notmuch-mutt/notmuch-mutt.1 %{buildroot}%{_mandir}/man1/notmuch-mutt.1
126 %post -p /sbin/ldconfig
128 %postun -p /sbin/ldconfig
131 %doc AUTHORS COPYING COPYING-GPL-3 INSTALL README
132 %{_sysconfdir}/bash_completion.d/notmuch
133 %{_datadir}/zsh/functions/Completion/Unix/_notmuch
136 %{_libdir}/libnotmuch.so.3*
139 %{_libdir}/libnotmuch.so
142 %files -n emacs-notmuch
143 %{_emacs_sitelispdir}/*
145 %files -n python-notmuch
146 %doc bindings/python/README
149 %files -n notmuch-ruby
150 %{ruby_vendorarchdir}/*
153 %{_bindir}/notmuch-mutt
154 %{_mandir}/man1/notmuch-mutt.1*
157 * Sun Apr 28 2013 Felipe Contreras <felipe.contreras@gmail.com> - 0.15.2-3
160 * Sun Apr 28 2013 Felipe Contreras <felipe.contreras@gmail.com> - 0.15.2-2
163 * Sun Apr 28 2013 Felipe Contreras <felipe.contreras@gmail.com> - 0.15.2-1
164 - Update to latest upstream
166 * Tue Nov 2 2010 Scott Henson <shenson@redhat.com> - 0.4-1
167 - New upstream release
169 * Wed Nov 18 2009 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.0-0.3.306635c2