]> git.cworth.org Git - notmuch/blobdiff - debian/patches/debian-changes
Merge branch 'release'
[notmuch] / debian / patches / debian-changes
index de0f871b36574dc454d8acddfb26622cb8cb6df8..40ee7d00a7806899b2a424bab9eee2741bfabbac 100644 (file)
@@ -3,32 +3,14 @@ delta against upstream is either kept as a single patch, or maintained
 in some VCS, and exported as a single patch instead of more manageable
 atomic patches.
 
---- notmuch-0.31.1.orig/devel/release-checks.sh
-+++ notmuch-0.31.1/devel/release-checks.sh
-@@ -29,7 +29,7 @@ append_emsg ()
-       emsgs="${emsgs:+$emsgs\n}  $1"
- }
+--- notmuch-0.31.2.orig/doc/Makefile.local
++++ notmuch-0.31.2/doc/Makefile.local
+@@ -43,7 +43,7 @@ INFO_INFO_FILES := $(INFO_TEXI_FILES:.te
+       rm -f $@ && gzip --no-name --stdout $^ > $@
  
--for f in ./version debian/changelog NEWS "$PV_FILE"
-+for f in ./version.txt debian/changelog NEWS "$PV_FILE"
- do
-       if   [ ! -f "$f" ]; then append_emsg "File '$f' is missing"
-       elif [ ! -r "$f" ]; then append_emsg "File '$f' is unreadable"
-@@ -53,7 +53,7 @@ then
- else
-       echo "Reading './version' file failed (surprisingly!)"
-       exit 1
--fi < ./version
-+fi < ./version.txt
+ ifeq ($(WITH_EMACS),1)
+-$(DOCBUILDDIR)/.roff.stamp sphinx-html sphinx-texinfo: docstring.stamp
++$(DOCBUILDDIR)/.roff.stamp $(DOCBUILDDIR)/.html.stamp $(DOCBUILDDIR)/.texi.stamp : docstring.stamp
+ endif
  
- readonly VERSION
-@@ -109,7 +109,7 @@ else
- fi
- echo -n "Checking that python bindings version is $VERSION... "
--py_version=`python -c "with open('$PV_FILE') as vf: exec(vf.read()); print(__VERSION__)"`
-+py_version=`python3 -c "with open('$PV_FILE') as vf: exec(vf.read()); print(__VERSION__)"`
- if [ "$py_version" = "$VERSION" ]
- then
-       echo Yes.
+ sphinx-html: $(DOCBUILDDIR)/.html.stamp