]> git.cworth.org Git - apitrace-tests/blobdiff - apps/CMakeLists.txt
d3d10.1 sample.
[apitrace-tests] / apps / CMakeLists.txt
index f75c9f851f7ffb2b580324338ce3f95a85c52270..9b1e886ddff63f320fb94b7e7bcf07388d046581 100644 (file)
@@ -24,7 +24,7 @@ function (ADD_APP_TEST)
     )
 endfunction ()
 
-if (OPENGL_FOUND)
+if (OPENGL_FOUND AND GLEW_FOUND AND GLUT_FOUND)
     add_subdirectory (gl)
 endif ()
 
@@ -32,6 +32,22 @@ if (EGL_FOUND)
     add_subdirectory (egl)
 endif ()
 
+if (DirectX_FXC_EXECUTABLE)
+    add_subdirectory (hlsl)
+endif ()
+
+if (DirectX_D3D11_FOUND)
+    add_subdirectory (d3d11)
+endif ()
+
+if (DirectX_D3D10_1_FOUND)
+    add_subdirectory (d3d10_1)
+endif ()
+
+if (DirectX_D3D10_FOUND)
+    add_subdirectory (d3d10)
+endif ()
+
 if (DirectX_D3D9_FOUND)
     add_subdirectory (d3d9)
 endif ()
@@ -39,3 +55,7 @@ endif ()
 if (DirectX_D3D8_FOUND)
     add_subdirectory (d3d8)
 endif ()
+
+if (DirectX_D3D_FOUND)
+    add_subdirectory (d3d7)
+endif ()