]> git.cworth.org Git - apitrace-tests/blobdiff - apps/CMakeLists.txt
Make OpenGL/GLUT/GLEW optional.
[apitrace-tests] / apps / CMakeLists.txt
index b824e2ba523d51206a06f7a2ed3f5dfe393b3b3c..b6225050ba59c6bb9695973492136fe5f506c7ed 100644 (file)
@@ -24,7 +24,7 @@ function (ADD_APP_TEST)
     )
 endfunction ()
 
-if (OPENGL_FOUND)
+if (OPENGL_FOUND AND GLEW_FOUND AND GLUT_FOUND)
     add_subdirectory (gl)
 endif ()
 
@@ -32,6 +32,10 @@ if (EGL_FOUND)
     add_subdirectory (egl)
 endif ()
 
+if (DirectX_D3D11_FOUND)
+    add_subdirectory (d3d11)
+endif ()
+
 if (DirectX_D3D10_FOUND)
     add_subdirectory (d3d10)
 endif ()