]> git.cworth.org Git - apitrace-tests/blobdiff - apps/CMakeLists.txt
Make OpenGL/GLUT/GLEW optional.
[apitrace-tests] / apps / CMakeLists.txt
index f75c9f851f7ffb2b580324338ce3f95a85c52270..b6225050ba59c6bb9695973492136fe5f506c7ed 100644 (file)
@@ -24,7 +24,7 @@ function (ADD_APP_TEST)
     )
 endfunction ()
 
-if (OPENGL_FOUND)
+if (OPENGL_FOUND AND GLEW_FOUND AND GLUT_FOUND)
     add_subdirectory (gl)
 endif ()
 
@@ -32,6 +32,14 @@ if (EGL_FOUND)
     add_subdirectory (egl)
 endif ()
 
+if (DirectX_D3D11_FOUND)
+    add_subdirectory (d3d11)
+endif ()
+
+if (DirectX_D3D10_FOUND)
+    add_subdirectory (d3d10)
+endif ()
+
 if (DirectX_D3D9_FOUND)
     add_subdirectory (d3d9)
 endif ()
@@ -39,3 +47,7 @@ endif ()
 if (DirectX_D3D8_FOUND)
     add_subdirectory (d3d8)
 endif ()
+
+if (DirectX_D3D_FOUND)
+    add_subdirectory (d3d7)
+endif ()