]> git.cworth.org Git - apitrace-tests/blobdiff - apps/d3d10/CMakeLists.txt
Prototype of d3d10 sample app.
[apitrace-tests] / apps / d3d10 / CMakeLists.txt
diff --git a/apps/d3d10/CMakeLists.txt b/apps/d3d10/CMakeLists.txt
new file mode 100644 (file)
index 0000000..e94e463
--- /dev/null
@@ -0,0 +1,28 @@
+include_directories (
+    ${DirectX_D3D10_INCLUDE_DIR}
+    ${APITRACE_SOURCE_DIR}/dispatch
+)
+
+link_libraries (
+    ${DirectX_D3D10_LIBRARY}
+)
+
+set (api d3d10)
+
+set (targets
+    tri
+)
+
+foreach (target ${targets})
+    add_executable (${api}_${target} WIN32 ${target}.cpp)
+    set_target_properties (${api}_${target} PROPERTIES OUTPUT_NAME ${target})
+
+    if (EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/${target}.ref.txt)
+        add_app_test(
+            NAME ${api}_${target}
+            TARGET ${api}_${target}
+            REF ${target}.ref.txt
+        )
+    endif ()
+endforeach (target)
+