]> git.cworth.org Git - apitrace-tests/blobdiff - apps/d3d11/CMakeLists.txt
d3d11 test.
[apitrace-tests] / apps / d3d11 / CMakeLists.txt
diff --git a/apps/d3d11/CMakeLists.txt b/apps/d3d11/CMakeLists.txt
new file mode 100644 (file)
index 0000000..5517cd4
--- /dev/null
@@ -0,0 +1,29 @@
+include_directories (
+    ${CMAKE_CURRENT_SOURCE_DIR}/../d3d10
+    ${APITRACE_SOURCE_DIR}/dispatch
+    ${DirectX_D3D11_INCLUDE_DIR}
+)
+
+link_libraries (
+    ${DirectX_D3D11_LIBRARY}
+)
+
+set (api d3d11)
+
+set (targets
+    tri
+)
+
+foreach (target ${targets})
+    add_executable (${api}_${target} ${target}.cpp)
+    set_target_properties (${api}_${target} PROPERTIES OUTPUT_NAME ${target})
+
+    if (EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/${target}.ref.txt)
+        add_app_test(
+            NAME ${api}_${target}
+            TARGET ${api}_${target}
+            REF ${target}.ref.txt
+        )
+    endif ()
+endforeach (target)
+