]> git.cworth.org Git - apitrace-tests/blobdiff - apps/egl/eglut/CMakeLists.txt
Add egl apps.
[apitrace-tests] / apps / egl / eglut / CMakeLists.txt
diff --git a/apps/egl/eglut/CMakeLists.txt b/apps/egl/eglut/CMakeLists.txt
new file mode 100644 (file)
index 0000000..08b2257
--- /dev/null
@@ -0,0 +1,12 @@
+include_directories (
+       ${EGL_INCLUDE_DIRS}
+)
+
+if (X11_FOUND)
+       add_library (eglut eglut.c eglut_x11.c)
+       target_link_libraries (eglut ${EGL_LIBRARIES} ${X11_X11_LIB})
+else ()
+       add_library (eglut eglut.c eglut_screen.c)
+       target_link_libraries (eglut ${EGL_LIBRARIES})
+endif ()
+