]> git.cworth.org Git - apitrace-tests/blobdiff - apps/egl/gl/CMakeLists.txt
Add egl apps.
[apitrace-tests] / apps / egl / gl / CMakeLists.txt
diff --git a/apps/egl/gl/CMakeLists.txt b/apps/egl/gl/CMakeLists.txt
new file mode 100644 (file)
index 0000000..1f4c606
--- /dev/null
@@ -0,0 +1,17 @@
+include_directories(
+    ${CMAKE_CURRENT_SOURCE_DIR}/../eglut
+    ${EGL_INCLUDE_DIRS}
+    ${OPENGL_INCLUDE_PATH}
+)
+
+set (api egl)
+
+set (targets
+    tri
+)
+
+foreach (target ${targets})
+    add_executable (${api}_${target} ${target}.c)
+    set_target_properties (${api}_${target} PROPERTIES OUTPUT_NAME ${target})
+    target_link_libraries (${api}_${target} eglut ${OPENGL_gl_LIBRARY})
+endforeach (target)