]> git.cworth.org Git - apitrace-tests/blobdiff - apps/egl/gl/CMakeLists.txt
Automate egl_tri test.
[apitrace-tests] / apps / egl / gl / CMakeLists.txt
index 1f4c60620bbaaed35f498ae636656577882fe38f..24eec7598f9318e886a69a3de84929de6a3fb0ac 100644 (file)
@@ -14,4 +14,12 @@ foreach (target ${targets})
     add_executable (${api}_${target} ${target}.c)
     set_target_properties (${api}_${target} PROPERTIES OUTPUT_NAME ${target})
     target_link_libraries (${api}_${target} eglut ${OPENGL_gl_LIBRARY})
+    
+    if (EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/${target}.ref.txt)
+        add_app_test(
+            NAME ${api}_${target}
+           TARGET ${api}_${target}
+           REF ${target}.ref.txt
+        )
+    endif ()
 endforeach (target)