]> git.cworth.org Git - apitrace-tests/blobdiff - apps/egl/gl/CMakeLists.txt
Distinguish FF tri from GLSL tri.
[apitrace-tests] / apps / egl / gl / CMakeLists.txt
index 1f4c60620bbaaed35f498ae636656577882fe38f..4b6532cea7e5a33be2ec0fc44cebbb220819ce2d 100644 (file)
@@ -8,10 +8,19 @@ set (api egl)
 
 set (targets
     tri
+    tri_glsl
 )
 
 foreach (target ${targets})
     add_executable (${api}_${target} ${target}.c)
     set_target_properties (${api}_${target} PROPERTIES OUTPUT_NAME ${target})
     target_link_libraries (${api}_${target} eglut ${OPENGL_gl_LIBRARY})
+    
+    if (EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/${target}.ref.txt)
+        add_app_test(
+            NAME ${api}_${target}
+            TARGET ${api}_${target}
+            REF ${target}.ref.txt
+        )
+    endif ()
 endforeach (target)