]> git.cworth.org Git - apitrace-tests/blobdiff - apps/egl/gles1/CMakeLists.txt
Automate gles tests.
[apitrace-tests] / apps / egl / gles1 / CMakeLists.txt
index 96e300da36fa1debeddf259952f75c5a7f078205..36937ab3177966e40f8751032998d3b92839c9fb 100644 (file)
@@ -15,4 +15,13 @@ foreach (target ${targets})
     add_executable (${api}_${target} ${target}.c)
     set_target_properties (${api}_${target} PROPERTIES OUTPUT_NAME ${target})
     target_link_libraries (${api}_${target} eglut ${GLESV1_LIBRARIES})
+
+    
+    if (EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/${target}.ref.txt)
+        add_app_test(
+            NAME ${api}_${target}
+            TARGET ${api}_${target}
+            REF ${target}.ref.txt
+        )
+    endif ()
 endforeach (target)