]> git.cworth.org Git - apitrace-tests/blobdiff - apps/egl/gles2/CMakeLists.txt
Add egl apps.
[apitrace-tests] / apps / egl / gles2 / CMakeLists.txt
diff --git a/apps/egl/gles2/CMakeLists.txt b/apps/egl/gles2/CMakeLists.txt
new file mode 100644 (file)
index 0000000..a45efdc
--- /dev/null
@@ -0,0 +1,19 @@
+include_directories(
+    ${CMAKE_CURRENT_SOURCE_DIR}/../eglut
+    ${EGL_INCLUDE_DIRS}
+    ${GLESV2_INCLUDE_DIRS}
+)
+
+set (api gles2)
+
+set (targets
+    tri
+)
+
+if (X11_FOUND)
+    foreach (target ${targets})
+       add_executable (${api}_${target} ${target}.c)
+       set_target_properties (${api}_${target} PROPERTIES OUTPUT_NAME ${target})
+       target_link_libraries (${api}_${target} ${EGL_LIBRARIES} ${GLESV2_LIBRARIES})
+    endforeach (target)
+endif ()