]> git.cworth.org Git - apitrace-tests/blobdiff - apps/egl/gles2/CMakeLists.txt
Distinguish FF tri from GLSL tri.
[apitrace-tests] / apps / egl / gles2 / CMakeLists.txt
index a45efdc2bd37fc3645a8e244a489be3435c92f36..ce8d4bd0c8a84402ca0e219e6473fdfb9c923b33 100644 (file)
@@ -7,13 +7,21 @@ include_directories(
 set (api gles2)
 
 set (targets
-    tri
+    tri_glsl
 )
 
 if (X11_FOUND)
     foreach (target ${targets})
-       add_executable (${api}_${target} ${target}.c)
-       set_target_properties (${api}_${target} PROPERTIES OUTPUT_NAME ${target})
-       target_link_libraries (${api}_${target} ${EGL_LIBRARIES} ${GLESV2_LIBRARIES})
+        add_executable (${api}_${target} ${target}.c)
+        set_target_properties (${api}_${target} PROPERTIES OUTPUT_NAME ${target})
+        target_link_libraries (${api}_${target} ${EGL_LIBRARIES} ${GLESV2_LIBRARIES})
+
+        if (EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/${target}.ref.txt)
+            add_app_test(
+                NAME ${api}_${target}
+                TARGET ${api}_${target}
+                REF ${target}.ref.txt
+            )
+        endif ()
     endforeach (target)
 endif ()