]> git.cworth.org Git - apitrace-tests/blobdiff - apps/gl/CMakeLists.txt
Start compiling apps for regression testing.
[apitrace-tests] / apps / gl / CMakeLists.txt
diff --git a/apps/gl/CMakeLists.txt b/apps/gl/CMakeLists.txt
new file mode 100644 (file)
index 0000000..a6be3d0
--- /dev/null
@@ -0,0 +1,24 @@
+include_directories (
+       ${OPENGL_INCLUDE_PATH}
+       ${GLUT_INCLUDE_DIR}
+       ${GLEW_INCLUDE_DIR}
+)
+
+link_libraries (
+       ${GLUT_glut_LIBRARY}
+       ${GLEW_glew_LIBRARY}
+       ${OPENGL_glu_LIBRARY}
+       ${OPENGL_gl_LIBRARY}
+)
+
+set (subdir gl)
+
+set (targets
+       tri
+)
+
+foreach (target ${targets})
+       add_executable (${subdir}_${target} ${target}.c)
+       set_target_properties (${subdir}_${target} PROPERTIES OUTPUT_NAME ${target})
+       install (TARGETS ${subdir}_${target} DESTINATION ${subdir})
+endforeach (target)