]> git.cworth.org Git - apitrace/blobdiff - cli/CMakeLists.txt
trim: Use custom skiplist for required list (instead of std::set<unsigned>)
[apitrace] / cli / CMakeLists.txt
index 5f8e116f5279e385ba1875ed659246bbf2c10d79..3165f7da662abf4bf8007f50ea474f8d3bb626de 100644 (file)
@@ -24,6 +24,7 @@ add_executable (apitrace
     cli_trim.cpp
     cli_resources.cpp
     trace_analyzer.cpp
+    trim_callset.cpp
 )
 
 target_link_libraries (apitrace
@@ -33,4 +34,11 @@ target_link_libraries (apitrace
     ${GETOPT_LIBRARIES}
 )
 
+if (NOT CMAKE_CROSSCOMPILING)
+    set_target_properties (apitrace PROPERTIES
+        # On debug builds tell where the source is so that scripts can be found
+        COMPILE_DEFINITIONS_DEBUG APITRACE_SOURCE_DIR="${CMAKE_SOURCE_DIR}"
+    )
+endif ()
+
 install (TARGETS apitrace RUNTIME DESTINATION bin)