]> git.cworth.org Git - apitrace/blobdiff - cli/CMakeLists.txt
cli: Fix script search for out of source build.
[apitrace] / cli / CMakeLists.txt
index 5f8e116f5279e385ba1875ed659246bbf2c10d79..689374dc5333ade934d45ea2a398e57d7182cec5 100644 (file)
@@ -33,4 +33,11 @@ target_link_libraries (apitrace
     ${GETOPT_LIBRARIES}
 )
 
+if (NOT CMAKE_CROSSCOMPILING)
+    set_target_properties (apitrace PROPERTIES
+        # On debug builds tell where the source is so that scripts can be found
+        COMPILE_DEFINITIONS_DEBUG APITRACE_SOURCE_DIR="${CMAKE_SOURCE_DIR}"
+    )
+endif ()
+
 install (TARGETS apitrace RUNTIME DESTINATION bin)