]> git.cworth.org Git - apitrace/blobdiff - cli/CMakeLists.txt
Rename trim::CallSet to trace::FastCallSet
[apitrace] / cli / CMakeLists.txt
index e5ad36d990979e84e921bf9008d8b14d15489353..689374dc5333ade934d45ea2a398e57d7182cec5 100644 (file)
@@ -23,6 +23,7 @@ add_executable (apitrace
     cli_trace.cpp
     cli_trim.cpp
     cli_resources.cpp
+    trace_analyzer.cpp
 )
 
 target_link_libraries (apitrace
@@ -32,4 +33,11 @@ target_link_libraries (apitrace
     ${GETOPT_LIBRARIES}
 )
 
+if (NOT CMAKE_CROSSCOMPILING)
+    set_target_properties (apitrace PROPERTIES
+        # On debug builds tell where the source is so that scripts can be found
+        COMPILE_DEFINITIONS_DEBUG APITRACE_SOURCE_DIR="${CMAKE_SOURCE_DIR}"
+    )
+endif ()
+
 install (TARGETS apitrace RUNTIME DESTINATION bin)