]> git.cworth.org Git - apitrace/blobdiff - thirdparty/snappy/CMakeLists.txt
Install all thirdparty licenses.
[apitrace] / thirdparty / snappy / CMakeLists.txt
index 9bbecdba6d2b9971654f8a7bb706ea702c252626..25281a6b981cbadb818dced2f75dec654582c011 100644 (file)
@@ -8,7 +8,7 @@ if (CMAKE_COMPILER_IS_GNUCXX)
     add_definitions (-Wno-unused-function)
 endif ()
 
-add_library (snappy_bundled STATIC
+add_library (snappy_bundled STATIC EXCLUDE_FROM_ALL
     snappy.cc
     snappy-sinksource.cc
     snappy-stubs-internal.cc
@@ -18,3 +18,9 @@ add_library (snappy_bundled STATIC
 set_target_properties (snappy_bundled PROPERTIES
     COMPILE_FLAGS "${CMAKE_SHARED_LIBRARY_CXX_FLAGS}"
 )
+
+install (
+    FILES COPYING
+    DESTINATION ${DOC_INSTALL_DIR}
+    RENAME LICENSE-snappy.txt
+)