]> git.cworth.org Git - apitrace/blobdiff - thirdparty/snappy/CMakeLists.txt
Fix mixed in/out of source builds.
[apitrace] / thirdparty / snappy / CMakeLists.txt
index 2ee896cb39039909c3d0a3bf80126ed9a733fcaa..bcacda7514a8acf632548d73fcff59e01d78d161 100644 (file)
@@ -44,3 +44,12 @@ add_library (snappy_bundled STATIC
 set_target_properties (snappy_bundled PROPERTIES
     COMPILE_FLAGS "${CMAKE_SHARED_LIBRARY_CXX_FLAGS}"
 )
+
+# If we're doing an out of source build remove any config.h from the source tree.
+if (NOT CMAKE_CURRENT_SOURCE_DIR STREQUAL CMAKE_CURRENT_BINARY_DIR)
+    add_custom_command (
+        TARGET snappy_bundled
+        PRE_BUILD
+        COMMAND ${CMAKE_COMMAND} -E remove -f ${CMAKE_CURRENT_SOURCE_DIR}/config.h
+    )
+endif()