]> git.cworth.org Git - apitrace/blobdiff - thirdparty/zlib/CMakeLists.txt
Install all thirdparty licenses.
[apitrace] / thirdparty / zlib / CMakeLists.txt
index b1e953d12bac221e6da86380bc4221c9129dd02a..3cf970ee552ff2331a97396106801856ee0770b2 100644 (file)
@@ -9,7 +9,7 @@ else ()
     add_definitions (-DHAVE_UNISTD_H)
 endif ()
 
-add_library (z_bundled STATIC
+add_library (z_bundled STATIC EXCLUDE_FROM_ALL
     adler32.c
     compress.c
     crc32.c
@@ -30,3 +30,9 @@ add_library (z_bundled STATIC
 set_target_properties (z_bundled PROPERTIES
     COMPILE_FLAGS "${CMAKE_SHARED_LIBRARY_C_FLAGS}"
 )
+
+install (
+    FILES README
+    DESTINATION ${DOC_INSTALL_DIR}
+    RENAME LICENSE-zlib.txt
+)