]> git.cworth.org Git - notmuch/blobdiff - debian/patches/debian-changes
Commit Debian 3.0 (quilt) metadata
[notmuch] / debian / patches / debian-changes
index de0f871b36574dc454d8acddfb26622cb8cb6df8..3e6eefca8b61959bbfe187e48a21fdf6c1d04f06 100644 (file)
@@ -3,32 +3,28 @@ delta against upstream is either kept as a single patch, or maintained
 in some VCS, and exported as a single patch instead of more manageable
 atomic patches.
 
---- notmuch-0.31.1.orig/devel/release-checks.sh
-+++ notmuch-0.31.1/devel/release-checks.sh
-@@ -29,7 +29,7 @@ append_emsg ()
-       emsgs="${emsgs:+$emsgs\n}  $1"
- }
+--- notmuch-0.31.2.orig/doc/Makefile.local
++++ notmuch-0.31.2/doc/Makefile.local
+@@ -43,7 +43,7 @@ INFO_INFO_FILES := $(INFO_TEXI_FILES:.te
+       rm -f $@ && gzip --no-name --stdout $^ > $@
  
--for f in ./version debian/changelog NEWS "$PV_FILE"
-+for f in ./version.txt debian/changelog NEWS "$PV_FILE"
- do
-       if   [ ! -f "$f" ]; then append_emsg "File '$f' is missing"
-       elif [ ! -r "$f" ]; then append_emsg "File '$f' is unreadable"
-@@ -53,7 +53,7 @@ then
- else
-       echo "Reading './version' file failed (surprisingly!)"
-       exit 1
--fi < ./version
-+fi < ./version.txt
+ ifeq ($(WITH_EMACS),1)
+-$(DOCBUILDDIR)/.roff.stamp sphinx-html sphinx-texinfo: docstring.stamp
++$(DOCBUILDDIR)/.roff.stamp $(DOCBUILDDIR)/.html.stamp $(DOCBUILDDIR)/.texi.stamp : docstring.stamp
+ endif
  
- readonly VERSION
+ sphinx-html: $(DOCBUILDDIR)/.html.stamp
+--- notmuch-0.31.2.orig/test/T360-symbol-hiding.sh
++++ notmuch-0.31.2/test/T360-symbol-hiding.sh
+@@ -26,8 +26,9 @@ test_begin_subtest 'checking output'
+ test_expect_equal "$result" "$output"
  
-@@ -109,7 +109,7 @@ else
- fi
+ test_begin_subtest 'comparing existing to exported symbols'
+-nm -P $NOTMUCH_BUILDDIR/lib/libnotmuch.so | awk '$2 == "T" && $1 ~ "^notmuch" {print $1}' | sort | uniq > ACTUAL
+-sed -n 's/^\(notmuch_[a-zA-Z0-9_]*\)[[:blank:]]*(.*/\1/p' $NOTMUCH_SRCDIR/lib/notmuch.h | sort | uniq > EXPORTED
++readelf -Ws $NOTMUCH_BUILDDIR/lib/libnotmuch.so | \
++    awk '$4 == "FUNC" && $5 == "GLOBAL" && $7 != "UND" {print $8}' | sort -u > ACTUAL
++sed -n 's/^\(notmuch_[a-zA-Z0-9_]*\)[[:blank:]]*(.*/\1/p' $NOTMUCH_SRCDIR/lib/notmuch.h | sort -u > EXPORTED
+ test_expect_equal_file EXPORTED ACTUAL
  
- echo -n "Checking that python bindings version is $VERSION... "
--py_version=`python -c "with open('$PV_FILE') as vf: exec(vf.read()); print(__VERSION__)"`
-+py_version=`python3 -c "with open('$PV_FILE') as vf: exec(vf.read()); print(__VERSION__)"`
- if [ "$py_version" = "$VERSION" ]
- then
-       echo Yes.
+ test_done