]> git.cworth.org Git - notmuch/blobdiff - debian/patches/debian-changes
Merge remote-tracking branch 'origin/debian/bullseye' into release
[notmuch] / debian / patches / debian-changes
index 55aa7de92e0336cf781811f5ffdc5275a9839155..d6927fd08433711bb7674a39c303fdf28f73d9ee 100644 (file)
@@ -3,45 +3,134 @@ delta against upstream is either kept as a single patch, or maintained
 in some VCS, and exported as a single patch instead of more manageable
 atomic patches.
 
---- notmuch-0.31.3.orig/Makefile.global
-+++ notmuch-0.31.3/Makefile.global
-@@ -36,7 +36,6 @@ endif
- endif
- UPSTREAM_TAG=$(subst ~,_,$(VERSION))
--DEB_TAG=debian/$(UPSTREAM_TAG)-1
- RELEASE_HOST=notmuchmail.org
- RELEASE_DIR=/srv/notmuchmail.org/www/releases
---- notmuch-0.31.3.orig/Makefile.local
-+++ notmuch-0.31.3/Makefile.local
-@@ -73,12 +73,11 @@ release: verify-source-tree-and-version
-       $(MAKE) VERSION=$(VERSION) $(SHA256_FILE) $(DETACHED_SIG_FILE)
-       ln -sf $(TAR_FILE) $(DEB_TAR_FILE)
-       pristine-tar commit $(DEB_TAR_FILE) $(UPSTREAM_TAG)
--      git tag -s -m "$(PACKAGE) Debian $(VERSION)-1 upload (same as $(VERSION))" $(DEB_TAG)
-       mkdir -p releases
-       mv $(TAR_FILE) $(SHA256_FILE) $(DETACHED_SIG_FILE) releases
-       $(MAKE) VERSION=$(VERSION) release-message > $(PACKAGE)-$(VERSION).announce
- ifeq ($(REALLY_UPLOAD),yes)
--      git push origin $(VERSION) $(DEB_TAG) release pristine-tar
-+      git push origin $(VERSION) release pristine-tar
-       cd releases && scp $(TAR_FILE) $(SHA256_FILE) $(DETACHED_SIG_FILE) $(RELEASE_HOST):$(RELEASE_DIR)
-       ssh $(RELEASE_HOST) "rm -f $(RELEASE_DIR)/LATEST-$(PACKAGE)-* ; ln -s $(TAR_FILE) $(RELEASE_DIR)/LATEST-$(TAR_FILE)"
-       rsync --verbose --delete --recursive doc/_build/html/ $(RELEASE_HOST):$(DOC_DIR)
-@@ -90,7 +89,6 @@ pre-release:
-       $(MAKE) VERSION=$(VERSION) clean
-       $(MAKE) VERSION=$(VERSION) test
-       git tag -s -m "$(PACKAGE) $(VERSION) release" $(UPSTREAM_TAG)
--      git tag -s -m "$(PACKAGE) Debian $(VERSION)-1 upload (same as $(VERSION))" $(DEB_TAG)
-       $(MAKE) VERSION=$(VERSION) $(SHA256_FILE) $(DETACHED_SIG_FILE)
-       ln -sf $(TAR_FILE) $(DEB_TAR_FILE)
-       pristine-tar commit $(DEB_TAR_FILE) $(UPSTREAM_TAG)
---- notmuch-0.31.3.orig/NEWS
-+++ notmuch-0.31.3/NEWS
-@@ -1,4 +1,5 @@
- Notmuch 0.31.3 (2020-12-25)
-+===========================
- Bindings
- --------
+--- notmuch-0.31.4.orig/lib/add-message.cc
++++ notmuch-0.31.4/lib/add-message.cc
+@@ -407,14 +407,17 @@ static notmuch_status_t
+ _notmuch_database_link_message (notmuch_database_t *notmuch,
+                               notmuch_message_t *message,
+                               notmuch_message_file_t *message_file,
+-                              bool is_ghost)
++                              bool is_ghost,
++                              bool is_new)
+ {
+     void *local = talloc_new (NULL);
+     notmuch_status_t status;
+     const char *thread_id = NULL;
+     /* Check if the message already had a thread ID */
+-    if (notmuch->features & NOTMUCH_FEATURE_GHOSTS) {
++    if (! is_new) {
++      thread_id = notmuch_message_get_thread_id (message);
++    } else if (notmuch->features & NOTMUCH_FEATURE_GHOSTS) {
+       if (is_ghost)
+           thread_id = notmuch_message_get_thread_id (message);
+     } else {
+@@ -539,7 +542,7 @@ notmuch_database_index_file (notmuch_dat
+       }
+       ret = _notmuch_database_link_message (notmuch, message,
+-                                            message_file, is_ghost);
++                                            message_file, is_ghost, is_new);
+       if (ret)
+           goto DONE;
+--- notmuch-0.31.4.orig/test/T357-index-decryption.sh
++++ notmuch-0.31.4/test/T357-index-decryption.sh
+@@ -112,12 +112,10 @@ test_expect_equal \
+     "$expected"
+ # try inserting it with decryption, should appear as a single copy
+-# (note: i think thread id skips 4 because of duplicate message-id
+-# insertion, above)
+ test_begin_subtest "message cleartext is present with insert --decrypt=true"
+ notmuch insert --folder=sent --decrypt=true <<<"$contents"
+-output=$(notmuch search wumpus)
+-expected='thread:0000000000000005   2000-01-01 [1/1] Notmuch Test Suite; test encrypted message for cleartext index 002 (encrypted inbox unread)'
++output=$(notmuch search wumpus | notmuch_search_sanitize)
++expected='thread:XXX   2000-01-01 [1/1] Notmuch Test Suite; test encrypted message for cleartext index 002 (encrypted inbox unread)'
+ test_expect_equal \
+     "$output" \
+     "$expected"
+@@ -127,9 +125,9 @@ test_expect_equal \
+ test_begin_subtest 'tagging all messages'
+ test_expect_success 'notmuch tag +blarney "encrypted message"'
+ test_begin_subtest "verify that tags have not changed"
+-output=$(notmuch search tag:blarney)
+-expected='thread:0000000000000001   2000-01-01 [1/1] Notmuch Test Suite; test encrypted message for cleartext index 001 (blarney encrypted inbox)
+-thread:0000000000000005   2000-01-01 [1/1] Notmuch Test Suite; test encrypted message for cleartext index 002 (blarney encrypted inbox unread)'
++output=$(notmuch search tag:blarney | notmuch_search_sanitize)
++expected='thread:XXX   2000-01-01 [1/1] Notmuch Test Suite; test encrypted message for cleartext index 001 (blarney encrypted inbox)
++thread:XXX   2000-01-01 [1/1] Notmuch Test Suite; test encrypted message for cleartext index 002 (blarney encrypted inbox unread)'
+ test_expect_equal \
+     "$output" \
+     "$expected"
+@@ -138,14 +136,14 @@ test_expect_equal \
+ test_begin_subtest 'reindex old messages'
+ test_expect_success 'notmuch reindex --decrypt=true tag:encrypted and not property:index.decryption=success'
+ test_begin_subtest "reindexed encrypted message, including cleartext"
+-output=$(notmuch search wumpus)
++output=$(notmuch search wumpus | notmuch_search_sanitize)
+ test_expect_equal \
+     "$output" \
+     "$expected"
+ # and the same search, but by property ($expected is untouched):
+ test_begin_subtest "emacs search by property for both messages"
+-output=$(notmuch search property:index.decryption=success)
++output=$(notmuch search property:index.decryption=success | notmuch_search_sanitize)
+ test_expect_equal \
+     "$output" \
+     "$expected"
+@@ -154,7 +152,7 @@ test_expect_equal \
+ test_begin_subtest 'reindex in auto mode'
+ test_expect_success 'notmuch reindex tag:encrypted and property:index.decryption=success'
+ test_begin_subtest "reindexed encrypted messages, should not have changed"
+-output=$(notmuch search wumpus)
++output=$(notmuch search wumpus | notmuch_search_sanitize)
+ test_expect_equal \
+     "$output" \
+     "$expected"
+@@ -188,9 +186,9 @@ test_expect_equal \
+ # ensure that the tags remain even when we are dropping the cleartext.
+ test_begin_subtest "verify that tags remain without cleartext"
+-output=$(notmuch search tag:blarney)
+-expected='thread:0000000000000001   2000-01-01 [1/1] Notmuch Test Suite; test encrypted message for cleartext index 001 (blarney encrypted inbox)
+-thread:0000000000000005   2000-01-01 [1/1] Notmuch Test Suite; test encrypted message for cleartext index 002 (blarney encrypted inbox unread)'
++output=$(notmuch search tag:blarney | notmuch_search_sanitize)
++expected='thread:XXX   2000-01-01 [1/1] Notmuch Test Suite; test encrypted message for cleartext index 001 (blarney encrypted inbox)
++thread:XXX   2000-01-01 [1/1] Notmuch Test Suite; test encrypted message for cleartext index 002 (blarney encrypted inbox unread)'
+ test_expect_equal \
+     "$output" \
+     "$expected"
+@@ -199,7 +197,7 @@ test_begin_subtest "index cleartext with
+ test_expect_success "notmuch reindex --decrypt=nostash tag:blarney"
+ test_begin_subtest "Ensure that the indexed terms are present"
+-output=$(notmuch search wumpus)
++output=$(notmuch search wumpus | notmuch_search_sanitize)
+ test_expect_equal \
+     "$output" \
+     "$expected"
+--- notmuch-0.31.4.orig/test/T670-duplicate-mid.sh
++++ notmuch-0.31.4/test/T670-duplicate-mid.sh
+@@ -6,6 +6,19 @@ add_message '[id]="duplicate"' '[subject
+ add_message '[id]="duplicate"' '[subject]="message 2" [filename]=copy2'
+ add_message '[id]="duplicate"' '[subject]="message 0" [filename]=copy0'
++
++test_begin_subtest 'at most 1 thread-id per xapian document'
++db=${MAIL_DIR}/.notmuch/xapian
++for doc in $(xapian-delve -1 -t '' "$db" | grep '^[1-9]'); do
++    xapian-delve -1 -r "$doc" "$db" | grep -c '^G'
++done > OUTPUT.raw
++sort -u < OUTPUT.raw > OUTPUT
++cat <<EOF > EXPECTED
++0
++1
++EOF
++test_expect_equal_file EXPECTED OUTPUT
++
+ test_begin_subtest 'search: first indexed subject preserved'
+ cat <<EOF > EXPECTED
+ thread:XXX   2001-01-05 [1/1(3)] Notmuch Test Suite; message 1 (inbox unread)