]> git.cworth.org Git - notmuch/blobdiff - debian/rules
debian: start changelog for 0.35
[notmuch] / debian / rules
index 1d25f9c310fa27493fcb3544bb85703e891460f0..558671261bf0f93ae1e441ea2bb31e3267695a72 100755 (executable)
@@ -3,7 +3,7 @@
 export DEB_BUILD_MAINT_OPTIONS = hardening=+all
 
 %:
-       dh $@ --with python3,elpa
+       dh $@ --with python3,elpa,sphinxdoc
 
 override_dh_auto_configure:
        BASHCMD=/bin/bash ./configure --prefix=/usr \
@@ -16,10 +16,10 @@ override_dh_auto_configure:
                --localstatedir=/var
 
 override_dh_auto_test:
-       dh_auto_test -- V=1 NOTMUCH_SKIP_TESTS="libconfig.18 libconfig.31"
+       dh_auto_test -- V=1
 
 override_dh_auto_build:
-       dh_auto_build -- V=1
+       dh_auto_build -- V=1 all sphinx-html
        PYBUILD_NAME=notmuch dh_auto_build --buildsystem=pybuild --sourcedirectory bindings/python
        PYBUILD_NAME=notmuch2 dh_auto_build --buildsystem=pybuild --sourcedirectory bindings/python-cffi
        $(MAKE) -C contrib/notmuch-mutt