]> git.cworth.org Git - notmuch/blobdiff - debian/rules
debian: start changelog for 0.35
[notmuch] / debian / rules
index 8de49d0ff24343d177389a1783ccd60c6b72873a..558671261bf0f93ae1e441ea2bb31e3267695a72 100755 (executable)
@@ -3,7 +3,7 @@
 export DEB_BUILD_MAINT_OPTIONS = hardening=+all
 
 %:
-       dh $@ --with python3,elpa
+       dh $@ --with python3,elpa,sphinxdoc
 
 override_dh_auto_configure:
        BASHCMD=/bin/bash ./configure --prefix=/usr \
@@ -15,8 +15,11 @@ override_dh_auto_configure:
                --zshcompletiondir=/usr/share/zsh/vendor-completions \
                --localstatedir=/var
 
+override_dh_auto_test:
+       dh_auto_test -- V=1
+
 override_dh_auto_build:
-       dh_auto_build -- V=1
+       dh_auto_build -- V=1 all sphinx-html
        PYBUILD_NAME=notmuch dh_auto_build --buildsystem=pybuild --sourcedirectory bindings/python
        PYBUILD_NAME=notmuch2 dh_auto_build --buildsystem=pybuild --sourcedirectory bindings/python-cffi
        $(MAKE) -C contrib/notmuch-mutt