]> git.cworth.org Git - notmuch/blobdiff - debian/rules
debian: start changelog for 0.35
[notmuch] / debian / rules
index bf9d0bbdc7379ca39e25a436127cee91f06e551e..558671261bf0f93ae1e441ea2bb31e3267695a72 100755 (executable)
@@ -1,11 +1,9 @@
 #!/usr/bin/make -f
 
-export PYBUILD_NAME=notmuch
-
 export DEB_BUILD_MAINT_OPTIONS = hardening=+all
 
 %:
-       dh $@ --with python3,elpa
+       dh $@ --with python3,elpa,sphinxdoc
 
 override_dh_auto_configure:
        BASHCMD=/bin/bash ./configure --prefix=/usr \
@@ -17,19 +15,25 @@ override_dh_auto_configure:
                --zshcompletiondir=/usr/share/zsh/vendor-completions \
                --localstatedir=/var
 
+override_dh_auto_test:
+       dh_auto_test -- V=1
+
 override_dh_auto_build:
-       dh_auto_build -- V=1
-       dh_auto_build --buildsystem=pybuild --sourcedirectory bindings/python
+       dh_auto_build -- V=1 all sphinx-html
+       PYBUILD_NAME=notmuch dh_auto_build --buildsystem=pybuild --sourcedirectory bindings/python
+       PYBUILD_NAME=notmuch2 dh_auto_build --buildsystem=pybuild --sourcedirectory bindings/python-cffi
        $(MAKE) -C contrib/notmuch-mutt
 
 override_dh_auto_clean:
        dh_auto_clean
-       dh_auto_clean --buildsystem=pybuild --sourcedirectory bindings/python
+       PYBUILD_NAME=notmuch dh_auto_clean --buildsystem=pybuild --sourcedirectory bindings/python
+       PYBUILD_NAME=notmuch2 dh_auto_clean --buildsystem=pybuild --sourcedirectory bindings/python-cffi
        dh_auto_clean --sourcedirectory bindings/ruby
        $(MAKE) -C contrib/notmuch-mutt clean
 
 override_dh_auto_install:
        dh_auto_install
-       dh_auto_install --buildsystem=pybuild --sourcedirectory bindings/python
+       PYBUILD_NAME=notmuch dh_auto_install --buildsystem=pybuild --sourcedirectory bindings/python
+       PYBUILD_NAME=notmuch2 dh_auto_install --buildsystem=pybuild --sourcedirectory bindings/python-cffi
        $(MAKE) -C contrib/notmuch-mutt DESTDIR=$(CURDIR)/debian/tmp install
        dh_auto_install --sourcedirectory bindings/ruby