]> git.cworth.org Git - notmuch/blobdiff - debian/rules
debian: changelog for 0.32.1-1
[notmuch] / debian / rules
index bf9d0bbdc7379ca39e25a436127cee91f06e551e..fa0551a951906e686860d08a78c615f24af6e3b0 100755 (executable)
@@ -1,7 +1,5 @@
 #!/usr/bin/make -f
 
-export PYBUILD_NAME=notmuch
-
 export DEB_BUILD_MAINT_OPTIONS = hardening=+all
 
 %:
@@ -17,19 +15,25 @@ override_dh_auto_configure:
                --zshcompletiondir=/usr/share/zsh/vendor-completions \
                --localstatedir=/var
 
+override_dh_auto_test:
+       dh_auto_test -- V=1
+
 override_dh_auto_build:
        dh_auto_build -- V=1
-       dh_auto_build --buildsystem=pybuild --sourcedirectory bindings/python
+       PYBUILD_NAME=notmuch dh_auto_build --buildsystem=pybuild --sourcedirectory bindings/python
+       PYBUILD_NAME=notmuch2 dh_auto_build --buildsystem=pybuild --sourcedirectory bindings/python-cffi
        $(MAKE) -C contrib/notmuch-mutt
 
 override_dh_auto_clean:
        dh_auto_clean
-       dh_auto_clean --buildsystem=pybuild --sourcedirectory bindings/python
+       PYBUILD_NAME=notmuch dh_auto_clean --buildsystem=pybuild --sourcedirectory bindings/python
+       PYBUILD_NAME=notmuch2 dh_auto_clean --buildsystem=pybuild --sourcedirectory bindings/python-cffi
        dh_auto_clean --sourcedirectory bindings/ruby
        $(MAKE) -C contrib/notmuch-mutt clean
 
 override_dh_auto_install:
        dh_auto_install
-       dh_auto_install --buildsystem=pybuild --sourcedirectory bindings/python
+       PYBUILD_NAME=notmuch dh_auto_install --buildsystem=pybuild --sourcedirectory bindings/python
+       PYBUILD_NAME=notmuch2 dh_auto_install --buildsystem=pybuild --sourcedirectory bindings/python-cffi
        $(MAKE) -C contrib/notmuch-mutt DESTDIR=$(CURDIR)/debian/tmp install
        dh_auto_install --sourcedirectory bindings/ruby