]> git.cworth.org Git - ttt/blobdiff - src/Makefile.am
2005-12-02 Richard D. Worth <richard@theworths.org>
[ttt] / src / Makefile.am
index 792b1ecc7ce42e5b1803e1eb24df180b8c0f405f..1d5de3f7669f20af0daa85e2f09edf2e73266f81 100644 (file)
@@ -1,10 +1,14 @@
 bin_PROGRAMS = ttt-server ttt-client
+noinst_PROGRAMS = test-board
 
 ttt_common_sources =           \
        ttt-args.c              \
        ttt-args.h              \
        ttt-board.c             \
        ttt-board.h             \
+       ttt-error.c             \
+       ttt-error.h             \
+       ttt-lex.l               \
        ttt-socket.c            \
        ttt-socket.h            \
        x.c                     \
@@ -12,12 +16,20 @@ ttt_common_sources =                \
 
 ttt_client_SOURCES =           \
        $(ttt_common_sources)   \
-       ttt-client.c
+       ttt.c
 
 ttt_server_SOURCES =           \
        $(ttt_common_sources)   \
+       ttt-client.c            \
        ttt-server.c
 
+test_board_SOURCES =           \
+       $(ttt_common_sources)   \
+       test-board.c
+
 AM_CFLAGS = $(WARN_CFLAGS) $(TTT_CFLAGS)
+AM_LFLAGS = --header-file=ttt-lex.h -Cr
 ttt_client_LDFLAGS = $(TTT_LIBS)
-ttt_server_LDFLAGS = $(TTT_LIBS)
+ttt_server_LDFLAGS = $(TTT_LIBS) -lpthread
+test_board_LDFLAGS = $(TTT_LIBS)
+