]> git.cworth.org Git - ttt/blobdiff - src/Makefile.am
Deleted debugging code and changed return errors to fit protocol
[ttt] / src / Makefile.am
index 792b1ecc7ce42e5b1803e1eb24df180b8c0f405f..41756f9a763c2ae8f1d30ea1745454d6fe1cf0ef 100644 (file)
@@ -1,23 +1,44 @@
-bin_PROGRAMS = ttt-server ttt-client
+bin_PROGRAMS = ttt-server ttt-client ttt-curses-client
+noinst_PROGRAMS = test-board
 
 ttt_common_sources =           \
        ttt-args.c              \
        ttt-args.h              \
        ttt-board.c             \
        ttt-board.h             \
+       ttt-error.c             \
+       ttt-error.h             \
+       ttt-lex.l               \
+       ttt-lex.h               \
        ttt-socket.c            \
        ttt-socket.h            \
        x.c                     \
        x.h
 
+AM_LFLAGS = --header=ttt-lex.h -Cr
+ttt-lex.h: ttt-lex.l
+       $(SHELL) $(YLWRAP) $< $@ $@ -- $(LEXCOMPILE)
+
 ttt_client_SOURCES =           \
        $(ttt_common_sources)   \
-       ttt-client.c
+       ttt.c
 
 ttt_server_SOURCES =           \
        $(ttt_common_sources)   \
+       ttt-client.c            \
        ttt-server.c
 
+test_board_SOURCES =           \
+       $(ttt_common_sources)   \
+       test-board.c
+
+ttt_curses_client_SOURCES =     \
+       $(ttt_common_sources)   \
+       curses.h                \
+        ttt-curses-client.c
+
 AM_CFLAGS = $(WARN_CFLAGS) $(TTT_CFLAGS)
 ttt_client_LDFLAGS = $(TTT_LIBS)
-ttt_server_LDFLAGS = $(TTT_LIBS)
+ttt_server_LDFLAGS = $(TTT_LIBS) -lpthread
+test_board_LDFLAGS = $(TTT_LIBS)
+ttt_curses_client_LDFLAGS = $(TTT_LIBS) -lncurses