]> git.cworth.org Git - ttt/blobdiff - src/Makefile.am
2005-12-08 Carl Worth <cworth@cworth.org>
[ttt] / src / Makefile.am
index 9ca2e53198bd8ae6755e37227b84e94fbeea35cc..41756f9a763c2ae8f1d30ea1745454d6fe1cf0ef 100644 (file)
@@ -9,11 +9,16 @@ ttt_common_sources =          \
        ttt-error.c             \
        ttt-error.h             \
        ttt-lex.l               \
+       ttt-lex.h               \
        ttt-socket.c            \
        ttt-socket.h            \
        x.c                     \
        x.h
 
+AM_LFLAGS = --header=ttt-lex.h -Cr
+ttt-lex.h: ttt-lex.l
+       $(SHELL) $(YLWRAP) $< $@ $@ -- $(LEXCOMPILE)
+
 ttt_client_SOURCES =           \
        $(ttt_common_sources)   \
        ttt.c
@@ -33,7 +38,6 @@ ttt_curses_client_SOURCES =     \
         ttt-curses-client.c
 
 AM_CFLAGS = $(WARN_CFLAGS) $(TTT_CFLAGS)
-AM_LFLAGS = --header-file=ttt-lex.h -Cr
 ttt_client_LDFLAGS = $(TTT_LIBS)
 ttt_server_LDFLAGS = $(TTT_LIBS) -lpthread
 test_board_LDFLAGS = $(TTT_LIBS)