]> git.cworth.org Git - ttt/blobdiff - src/Makefile.am
Ignore ttt-lex.h
[ttt] / src / Makefile.am
index c205ef940b4dfe060674cca5dcf5483c666227cb..41756f9a763c2ae8f1d30ea1745454d6fe1cf0ef 100644 (file)
@@ -1,4 +1,5 @@
-bin_PROGRAMS = ttt-server ttt-client
+bin_PROGRAMS = ttt-server ttt-client ttt-curses-client
+noinst_PROGRAMS = test-board
 
 ttt_common_sources =           \
        ttt-args.c              \
@@ -8,11 +9,16 @@ ttt_common_sources =          \
        ttt-error.c             \
        ttt-error.h             \
        ttt-lex.l               \
+       ttt-lex.h               \
        ttt-socket.c            \
        ttt-socket.h            \
        x.c                     \
        x.h
 
+AM_LFLAGS = --header=ttt-lex.h -Cr
+ttt-lex.h: ttt-lex.l
+       $(SHELL) $(YLWRAP) $< $@ $@ -- $(LEXCOMPILE)
+
 ttt_client_SOURCES =           \
        $(ttt_common_sources)   \
        ttt.c
@@ -22,7 +28,17 @@ ttt_server_SOURCES =                 \
        ttt-client.c            \
        ttt-server.c
 
+test_board_SOURCES =           \
+       $(ttt_common_sources)   \
+       test-board.c
+
+ttt_curses_client_SOURCES =     \
+       $(ttt_common_sources)   \
+       curses.h                \
+        ttt-curses-client.c
+
 AM_CFLAGS = $(WARN_CFLAGS) $(TTT_CFLAGS)
-AM_LFLAGS = --header-file=ttt-lex.h -Cr
 ttt_client_LDFLAGS = $(TTT_LIBS)
 ttt_server_LDFLAGS = $(TTT_LIBS) -lpthread
+test_board_LDFLAGS = $(TTT_LIBS)
+ttt_curses_client_LDFLAGS = $(TTT_LIBS) -lncurses