]> git.cworth.org Git - ttt/blobdiff - src/Makefile.am
2005-11-15 Carl Worth <cworth@cworth.org>
[ttt] / src / Makefile.am
index 2e7ae737fdbe35e2fc2e64c19bca5d1883358b1b..4b336a05d2d9ff0c6bf8d55df1e89abfb4a83b14 100644 (file)
@@ -5,21 +5,22 @@ ttt_common_sources =          \
        ttt-args.h              \
        ttt-board.c             \
        ttt-board.h             \
-       ttt-command.c           \
-       ttt-command.h           \
        ttt-error.c             \
        ttt-error.h             \
+       ttt-socket.c            \
+       ttt-socket.h            \
        x.c                     \
        x.h
 
 ttt_client_SOURCES =           \
        $(ttt_common_sources)   \
-       ttt-client.c
+       ttt.c
 
 ttt_server_SOURCES =           \
        $(ttt_common_sources)   \
+       ttt-client.c            \
        ttt-server.c
 
 AM_CFLAGS = $(WARN_CFLAGS) $(TTT_CFLAGS)
 ttt_client_LDFLAGS = $(TTT_LIBS)
-ttt_server_LDFLAGS = $(TTT_LIBS)
+ttt_server_LDFLAGS = $(TTT_LIBS) -lpthread