]> git.cworth.org Git - ttt/blobdiff - src/Makefile.am
2005-11-11 Carl Worth <cworth@cworth.org>
[ttt] / src / Makefile.am
index 9b52b44f86ae6b819e7ff40462dc8a941f5656fe..5619e522b5bd9ff35598c95fcb2c9ca0447a9402 100644 (file)
@@ -5,19 +5,20 @@ ttt_common_sources =          \
        ttt-args.h              \
        ttt-board.c             \
        ttt-board.h             \
-       ttt-command.c           \
-       ttt-command.h           \
-       ttt-error.c             \
-       ttt-error.h
+       ttt-socket.c            \
+       ttt-socket.h            \
+       x.c                     \
+       x.h
 
 ttt_client_SOURCES =           \
        $(ttt_common_sources)   \
-       ttt-client.c
+       ttt.c
 
 ttt_server_SOURCES =           \
        $(ttt_common_sources)   \
+       ttt-client.c            \
        ttt-server.c
 
 AM_CFLAGS = $(WARN_CFLAGS) $(TTT_CFLAGS)
 ttt_client_LDFLAGS = $(TTT_LIBS)
-ttt_server_LDFLAGS = $(TTT_LIBS)
+ttt_server_LDFLAGS = $(TTT_LIBS) -lpthread