]> git.cworth.org Git - ttt/blobdiff - src/Makefile.am
2005-11-11 Carl Worth <cworth@cworth.org>
[ttt] / src / Makefile.am
index b7bce5028b59caf92dcb9c4afe43542753bb28cd..5619e522b5bd9ff35598c95fcb2c9ca0447a9402 100644 (file)
@@ -1,9 +1,24 @@
-bin_PROGRAMS = ttt
+bin_PROGRAMS = ttt-server ttt-client
 
-ttt_SOURCES = \
-       args.c \
-       args.h \
+ttt_common_sources =           \
+       ttt-args.c              \
+       ttt-args.h              \
+       ttt-board.c             \
+       ttt-board.h             \
+       ttt-socket.c            \
+       ttt-socket.h            \
+       x.c                     \
+       x.h
+
+ttt_client_SOURCES =           \
+       $(ttt_common_sources)   \
        ttt.c
 
+ttt_server_SOURCES =           \
+       $(ttt_common_sources)   \
+       ttt-client.c            \
+       ttt-server.c
+
 AM_CFLAGS = $(WARN_CFLAGS) $(TTT_CFLAGS)
-ttt_LDFLAGS = $(TTT_LIBS)
+ttt_client_LDFLAGS = $(TTT_LIBS)
+ttt_server_LDFLAGS = $(TTT_LIBS) -lpthread