]> git.cworth.org Git - ttt/blobdiff - src/Makefile.am
2005-11-05 Carl Worth <cworth@cworth.org>
[ttt] / src / Makefile.am
index b7bce5028b59caf92dcb9c4afe43542753bb28cd..9b52b44f86ae6b819e7ff40462dc8a941f5656fe 100644 (file)
@@ -1,9 +1,23 @@
-bin_PROGRAMS = ttt
+bin_PROGRAMS = ttt-server ttt-client
 
 
-ttt_SOURCES = \
-       args.c \
-       args.h \
-       ttt.c
+ttt_common_sources =           \
+       ttt-args.c              \
+       ttt-args.h              \
+       ttt-board.c             \
+       ttt-board.h             \
+       ttt-command.c           \
+       ttt-command.h           \
+       ttt-error.c             \
+       ttt-error.h
+
+ttt_client_SOURCES =           \
+       $(ttt_common_sources)   \
+       ttt-client.c
+
+ttt_server_SOURCES =           \
+       $(ttt_common_sources)   \
+       ttt-server.c
 
 AM_CFLAGS = $(WARN_CFLAGS) $(TTT_CFLAGS)
 
 AM_CFLAGS = $(WARN_CFLAGS) $(TTT_CFLAGS)
-ttt_LDFLAGS = $(TTT_LIBS)
+ttt_client_LDFLAGS = $(TTT_LIBS)
+ttt_server_LDFLAGS = $(TTT_LIBS)