]> git.cworth.org Git - ttt/blobdiff - src/Makefile.am
2005-12-04 Bryan Worth <bryan@theworths.org>
[ttt] / src / Makefile.am
index c205ef940b4dfe060674cca5dcf5483c666227cb..9ca2e53198bd8ae6755e37227b84e94fbeea35cc 100644 (file)
@@ -1,4 +1,5 @@
-bin_PROGRAMS = ttt-server ttt-client
+bin_PROGRAMS = ttt-server ttt-client ttt-curses-client
+noinst_PROGRAMS = test-board
 
 ttt_common_sources =           \
        ttt-args.c              \
@@ -22,7 +23,18 @@ ttt_server_SOURCES =                 \
        ttt-client.c            \
        ttt-server.c
 
+test_board_SOURCES =           \
+       $(ttt_common_sources)   \
+       test-board.c
+
+ttt_curses_client_SOURCES =     \
+       $(ttt_common_sources)   \
+       curses.h                \
+        ttt-curses-client.c
+
 AM_CFLAGS = $(WARN_CFLAGS) $(TTT_CFLAGS)
 AM_LFLAGS = --header-file=ttt-lex.h -Cr
 ttt_client_LDFLAGS = $(TTT_LIBS)
 ttt_server_LDFLAGS = $(TTT_LIBS) -lpthread
+test_board_LDFLAGS = $(TTT_LIBS)
+ttt_curses_client_LDFLAGS = $(TTT_LIBS) -lncurses