]> git.cworth.org Git - ttt/blobdiff - src/Makefile.am
2005-11-22 Carl Worth <cworth@cworth.org>
[ttt] / src / Makefile.am
index 2e7ae737fdbe35e2fc2e64c19bca5d1883358b1b..c205ef940b4dfe060674cca5dcf5483c666227cb 100644 (file)
@@ -5,21 +5,24 @@ ttt_common_sources =          \
        ttt-args.h              \
        ttt-board.c             \
        ttt-board.h             \
-       ttt-command.c           \
-       ttt-command.h           \
        ttt-error.c             \
        ttt-error.h             \
+       ttt-lex.l               \
+       ttt-socket.c            \
+       ttt-socket.h            \
        x.c                     \
        x.h
 
 ttt_client_SOURCES =           \
        $(ttt_common_sources)   \
-       ttt-client.c
+       ttt.c
 
 ttt_server_SOURCES =           \
        $(ttt_common_sources)   \
+       ttt-client.c            \
        ttt-server.c
 
 AM_CFLAGS = $(WARN_CFLAGS) $(TTT_CFLAGS)
+AM_LFLAGS = --header-file=ttt-lex.h -Cr
 ttt_client_LDFLAGS = $(TTT_LIBS)
-ttt_server_LDFLAGS = $(TTT_LIBS)
+ttt_server_LDFLAGS = $(TTT_LIBS) -lpthread