]> git.cworth.org Git - vogl/blobdiff - src/vogleditor/CMakeLists.txt
UI: Add a settings file
[vogl] / src / vogleditor / CMakeLists.txt
index 15996cb82595d57d9b3ce0b52ae7e6394c876d5a..03d91a19fbf4d2b64a1e14be3ac2860e1a937c48 100644 (file)
@@ -2,13 +2,20 @@ project(vogleditor)
 cmake_minimum_required(VERSION 2.8.9)
 
 include("${SRC_DIR}/build_options.cmake")
+
+if (NOT DEFINED ENV{QTDIR})
+set(ENV{QTDIR} /usr/local/Trolltech/Qt-4.8.5)
+endif()
 find_package(Qt4 REQUIRED)
 
+find_package(Threads REQUIRED)
+find_package(X11 REQUIRED)
+
 include_directories(
     ${SRC_DIR}
     ${SRC_DIR}/voglcore
     ${SRC_DIR}/voglcommon
-    ${SRC_DIR}/voglinc
+    ${CMAKE_BINARY_DIR}/voglinc
     ${SRC_DIR}/extlib/loki/include/loki
     ${SRC_DIR}/libtelemetry
     ${CMAKE_CURRENT_BINARY_DIR}
@@ -46,6 +53,8 @@ set(SRC_LIST
     vogleditor_qtextureexplorer.cpp
     vogleditor_qtextureviewer.cpp
     vogleditor_qtimelineview.cpp
+    vogleditor_qtrimdialog.cpp
+    vogleditor_settings.cpp
     vogleditor_statetreearbprogramitem.cpp
     vogleditor_statetreearbprogramenvitem.cpp
     vogleditor_statetreebufferitem.cpp
@@ -84,6 +93,7 @@ set(UI_HEADER_LIST
     vogleditor_qtextureviewer.h
     vogleditor_qtextureexplorer.h
     vogleditor_qtimelineview.h
+    vogleditor_qtrimdialog.h
    )
 
 # these are for non-QOBJECT headers
@@ -94,6 +104,7 @@ set(HEADER_LIST
     vogleditor_apicalltreeitem.h
     vogleditor_frameitem.h
     vogleditor_gl_state_snapshot.h
+    vogleditor_settings.h
     vogleditor_snapshotitem.h
     vogleditor_statetreearbprogramitem.h
     vogleditor_statetreearbprogramenvitem.h
@@ -127,6 +138,7 @@ set(FORM_LIST
     vogleditor_qprogramexplorer.ui
     vogleditor_qshaderexplorer.ui
     vogleditor_qtextureexplorer.ui
+    vogleditor_qtrimdialog.ui
    )
 
 set(RESOURCE_LIST
@@ -144,14 +156,18 @@ add_executable(${PROJECT_NAME} ${SRC_LIST} ${HEADER_LIST}
         ${QT_GEN_RESOURCE_RCC_LIST}
    )
 
+add_dependencies(${PROJECT_NAME} voglgen_make_inc)
+
 target_link_libraries(${PROJECT_NAME}
        ${QT_QTMAIN_LIBRARY} 
        ${QT_QTCORE_LIBRARY} 
        ${QT_QTGUI_LIBRARY} 
        ${TELEMETRY_LIBRARY}
+       ${X11_X11_LIB}
        backtrace
        voglcommon
     voglcore
+    ${CMAKE_DL_LIBS}
    )
 
 build_options_finalize()