]> git.cworth.org Git - tar/blobdiff - debian/rules
Preserve timestamp of symlinks when extracting (if utimensat available)
[tar] / debian / rules
index 74bcc21c0c836e2802e171540f0468d17ba29a09..54246aecdd2afdbe506079dd2f76cae1a49d8951 100755 (executable)
@@ -15,14 +15,16 @@ configure-stamp:
                ./configure --prefix=/usr --libexecdir=/usr/sbin $(CONFARGS)
        touch configure-stamp
 
-build: configure-stamp build-stamp
-build-stamp:
+build: build-stamp
+build-stamp: configure-stamp
        dh_testdir
        RSH="/usr/bin/rsh" CFLAGS="-O2 -g -Wall -fno-gnu89-inline" $(MAKE)
 
+ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
 ifeq ($(DEB_BUILD_GNU_TYPE),$(DEB_HOST_GNU_TYPE))
        (cd tests ; $(MAKE) clean)
        $(MAKE) check
+endif
 endif
 
        perl debian/tarman > debian/tar.1