]> git.cworth.org Git - apitrace-tests/blobdiff - apps/CMakeLists.txt
Put HLSL shaders into their own directory.
[apitrace-tests] / apps / CMakeLists.txt
index b824e2ba523d51206a06f7a2ed3f5dfe393b3b3c..6412f68fca0ee8d942d3b70fb4ea78ff4976a9f0 100644 (file)
@@ -24,7 +24,7 @@ function (ADD_APP_TEST)
     )
 endfunction ()
 
-if (OPENGL_FOUND)
+if (OPENGL_FOUND AND GLEW_FOUND AND GLUT_FOUND)
     add_subdirectory (gl)
 endif ()
 
@@ -32,6 +32,14 @@ if (EGL_FOUND)
     add_subdirectory (egl)
 endif ()
 
+if (DirectX_FXC_EXECUTABLE)
+    add_subdirectory (hlsl)
+endif ()
+
+if (DirectX_D3D11_FOUND)
+    add_subdirectory (d3d11)
+endif ()
+
 if (DirectX_D3D10_FOUND)
     add_subdirectory (d3d10)
 endif ()