]> git.cworth.org Git - apitrace/blobdiff - wrappers/CMakeLists.txt
d3dtrace,d3dretrace: Move shader disassembly helpers to common location.
[apitrace] / wrappers / CMakeLists.txt
index 93be8e8f252963fb357108c25c0f9a4127589a49..8a0e7690810c988fb1a79a3aee86af64e146bc9d 100644 (file)
@@ -76,8 +76,13 @@ if (WIN32)
                 ${CMAKE_SOURCE_DIR}/specs/winapi.py
                 ${CMAKE_SOURCE_DIR}/specs/stdapi.py
         )
-        add_library (d3d8trace MODULE d3d8.def d3d8trace.cpp d3d9shader.cpp)
+        add_library (d3d8trace MODULE
+            d3d8.def
+            d3d8trace.cpp
+            d3d9shader.cpp
+        )
         target_link_libraries (d3d8trace
+            d3dhelpers
             common_trace
             common
             ${ZLIB_LIBRARIES}
@@ -108,8 +113,13 @@ if (WIN32)
                 ${CMAKE_SOURCE_DIR}/specs/winapi.py
                 ${CMAKE_SOURCE_DIR}/specs/stdapi.py
         )
-        add_library (d3d9trace MODULE d3d9.def d3d9trace.cpp d3d9shader.cpp)
+        add_library (d3d9trace MODULE
+            d3d9.def
+            d3d9trace.cpp
+            d3d9shader.cpp
+        )
         target_link_libraries (d3d9trace
+            d3dhelpers
             common_trace
             common
             ${ZLIB_LIBRARIES}
@@ -176,6 +186,7 @@ if (WIN32)
             d3dcommonshader.cpp
         )
         target_link_libraries (dxgitrace
+            d3dhelpers
             common_trace
             common
             ${ZLIB_LIBRARIES}