]> git.cworth.org Git - gzip/blobdiff - debian/rules
Imported Debian patch 1.3.12-4
[gzip] / debian / rules
index 931925b2451278f3f55bac8632c5fd6376f8635f..a6d19bf327526f370c46fe05fd63b3409d4b3d16 100755 (executable)
@@ -11,7 +11,12 @@ ifneq ($(DEB_BUILD_GNU_TYPE),$(DEB_HOST_GNU_TYPE))
 CONFARGS = --host=$(DEB_HOST_GNU_TYPE)
 endif
 
+buildarch := $(shell dpkg-architecture -qDEB_BUILD_ARCH)
+ifeq ($(buildarch),amd64)
+CFLAGS="-g -O2 -Wall -DUNALIGNED_OK"
+else
 CFLAGS="-g -O2 -Wall" 
+endif
 
 configure: configure-stamp
 configure-stamp: