]> git.cworth.org Git - tar/blobdiff - debian/rules
Fix to allow parallel build (-j2), closes #535319
[tar] / debian / rules
index c738c9f03fdf4404afea10fbd92810d8fd7376dd..6a369a4127c82ee60828e205cd5f618795ee26b1 100755 (executable)
@@ -15,25 +15,24 @@ configure-stamp:
                ./configure --prefix=/usr --libexecdir=/usr/sbin $(CONFARGS)
        touch configure-stamp
 
-build: configure-stamp build-stamp
-build-stamp:
+build: build-stamp
+build-stamp: configure-stamp
        dh_testdir
-
        RSH="/usr/bin/rsh" CFLAGS="-O2 -g -Wall -fno-gnu89-inline" $(MAKE)
+
 ifeq ($(DEB_BUILD_GNU_TYPE),$(DEB_HOST_GNU_TYPE))
        (cd tests ; $(MAKE) clean)
        $(MAKE) check
 endif
 
+       perl debian/tarman > debian/tar.1
        touch build-stamp
 
 clean:
        dh_testdir
        dh_testroot
-       rm -f build-stamp configure-stamp
-
+       rm -f build-stamp configure-stamp debian/tar.1
        [ ! -f Makefile ] || $(MAKE) distclean
-
        dh_clean
 
 install: build