]> git.cworth.org Git - tar/blobdiff - debian/rules
oops, forgot to merge this back in during repo reconstruction
[tar] / debian / rules
index c738c9f03fdf4404afea10fbd92810d8fd7376dd..74bcc21c0c836e2802e171540f0468d17ba29a09 100755 (executable)
@@ -18,22 +18,21 @@ configure-stamp:
 build: configure-stamp build-stamp
 build-stamp:
        dh_testdir
-
        RSH="/usr/bin/rsh" CFLAGS="-O2 -g -Wall -fno-gnu89-inline" $(MAKE)
+
 ifeq ($(DEB_BUILD_GNU_TYPE),$(DEB_HOST_GNU_TYPE))
        (cd tests ; $(MAKE) clean)
        $(MAKE) check
 endif
 
+       perl debian/tarman > debian/tar.1
        touch build-stamp
 
 clean:
        dh_testdir
        dh_testroot
-       rm -f build-stamp configure-stamp
-
+       rm -f build-stamp configure-stamp debian/tar.1
        [ ! -f Makefile ] || $(MAKE) distclean
-
        dh_clean
 
 install: build