]> git.cworth.org Git - tar/blobdiff - debian/rules
change the way config.{sub,guess} are updated to work better with git
[tar] / debian / rules
index a8b047fbfd3f27ab8e4b551277ab86ec204c092d..c738c9f03fdf4404afea10fbd92810d8fd7376dd 100755 (executable)
@@ -9,10 +9,10 @@ endif
 configure: configure-stamp
 configure-stamp:
        dh_testdir
-
+       cp -f /usr/share/misc/config.sub build-aux/config.sub
+       cp -f /usr/share/misc/config.guess build-aux/config.guess
        RSH="/usr/bin/rsh" CFLAGS="-O2 -g -Wall" \
                ./configure --prefix=/usr --libexecdir=/usr/sbin $(CONFARGS)
-
        touch configure-stamp
 
 build: configure-stamp build-stamp
@@ -34,11 +34,6 @@ clean:
 
        [ ! -f Makefile ] || $(MAKE) distclean
 
-       -test -r /usr/share/misc/config.sub && \
-               cp -f /usr/share/misc/config.sub build-aux/config.sub
-       -test -r /usr/share/misc/config.guess && \
-               cp -f /usr/share/misc/config.guess build-aux/config.guess
-
        dh_clean
 
 install: build