]> git.cworth.org Git - tar/blobdiff - doc/Makefile.am
Imported Upstream version 1.24
[tar] / doc / Makefile.am
index 1715d3566b9bd38dd6d110e822dfd0a5cb76e83c..205a1ad8e3bf9acdb64afaff468b6bc3e2c28583 100644 (file)
@@ -24,9 +24,9 @@ tar_TEXINFOS = \
  fdl.texi\
  freemanuals.texi\
  genfile.texi\
- getdate.texi\
  header.texi\
  intern.texi\
+ parse-datetime.texi\
  rendition.texi\
  snapshot.texi\
  sparse.texi\
@@ -59,25 +59,28 @@ check-format:
        fi
 
 check-options:
-       @ARGP_HELP_FMT='usage-indent=0,short-opt-col=0,long-opt-col=0,\
-doc-opt-col=0,opt-doc-col=0,header-col=0,rmargin=1' \
+       @ARGP_HELP_FMT='usage-indent=0,short-opt-col=0,long-opt-col=0,doc-opt-col=0,opt-doc-col=0,header-col=0,rmargin=1' \
        $(top_builddir)/src/tar --usage | \
        sed -n 's/^\[--\([^]\=\[]*\).*/\1/p' | sort | uniq > opts.$$$$;\
        $(MAKEINFO) $(AM_MAKEINFOFLAGS) $(MAKEINFOFLAGS) -I $(srcdir) -E - \
             $(info_TEXINFOS) | \
        sed -n '/^@macro/,/^@end macro/d;s/@opindex *\([^@,]*\).*/\1/p' \
             | sort | uniq > docs.$$$$;\
-       (echo 'Not documented options:';\
-        join -v1 opts.$$$$ docs.$$$$;\
-        echo 'Non-existing options:';\
-        join -v2 opts.$$$$ docs.$$$$) > report.$$$$;\
-        rm opts.$$$$ docs.$$$$;\
-        if [ -n "`sed '1,2d' report.$$$$`" ]; then \
-          cat report.$$$$;\
-          rm report.$$$$;\
-          exit 1;\
-        fi;\
-        rm report.$$$$
+       status=0;\
+       join -v1 opts.$$$$ docs.$$$$ > report.$$$$;\
+       if test -s report.$$$$; then \
+          echo 'Not documented options:'; \
+          cat report.$$$$; \
+          status=1; \
+        fi; \
+       join -v2 opts.$$$$ docs.$$$$ > report.$$$$;\
+       if test -s report.$$$$; then \
+         echo 'Non-existing options:';\
+          cat report.$$$$; \
+          status=1; \
+        fi; \
+       rm opts.$$$$ docs.$$$$ report.$$$$;\
+       test $$status -ne 0 && exit $$status
 
 check-refs:
        @for file in $(info_TEXINFOS) $(tar_TEXINFOS); \
@@ -121,7 +124,7 @@ check-unrevised:
 
 all-check-docs: check-format check-options check-refs check-fixmes check-unrevised
 
-check-docs: 
+check-docs:
        $(MAKE) -k all-check-docs
 
 #
@@ -141,4 +144,3 @@ manual:
         MAKEINFO="$(MAKEINFO) $(MAKEINFOFLAGS)" \
         TEXI2DVI="$(TEXI2DVI) -t @finalout" \
        $(GENDOCS) --texi2html tar 'GNU tar manual'
-