]> git.cworth.org Git - vogl/blob - glspec/glx.spec
Initial vogl checkin
[vogl] / glspec / glx.spec
1 # Copyright (c) 1991-2005 Silicon Graphics, Inc. All Rights Reserved.
2 # Copyright (c) 2006-2010 The Khronos Group, Inc.
3 #
4 # This document is licensed under the SGI Free Software B License Version
5 # 2.0. For details, see http://oss.sgi.com/projects/FreeB/ .
6 #
7 # $Revision: 17025 $ on $Date: 2012-03-05 03:01:59 -0800 (Mon, 05 Mar 2012) $
8
9 required-props:
10 param:          retval retained
11 dlflags:        notlistable handcode nop
12 glxflags:       client-handcode server-handcode
13 glxvendorglx:   *
14 vectorequiv:    *
15 category:       pixel-rw bgn-end display-list drawing drawing-control feedback framebuf misc modeling pixel-op pixel-rw state-req xform glx glxopcode
16 glxopcode:              *
17
18 ###############################################################################
19 #
20 # Missing commands
21 #
22 ###############################################################################
23 ChooseVisual(dpy, screen, attribList)
24         return          XVisualInfoPointer
25         param           dpy             Display in reference
26         param           screen  Int32 in value
27         param           attribList      Int32 in array[]
28         category        glx
29
30 GetConfig(dpy, vis, attrib, value)
31         return          Int32
32         param           dpy             Display in reference
33         param           vis XVisualInfo in reference
34         param           attrib Int32 in value
35         param           value Int32 out reference 
36         category        glx     
37         
38 QueryExtension(dpy, errorBase, eventBase)
39         return          Bool
40         param           dpy Display in reference
41         param           errorBase Int32 out reference
42         param           eventBase Int32 out reference
43         category        glx
44
45 GetClientString(dpy, name)
46         return          String
47         param           dpy Display in reference        
48         param           name Int32 in value
49         category        glx
50         
51 GetCurrentDrawable(dpy, name)
52         return          GLXDrawable
53         category        glx
54
55
56 ###############################################################################
57 #
58 # GLX1.0 commands
59 #
60 ###############################################################################
61
62 Render()
63         return           void
64         category         glx
65         dlflags          notlistable
66         glxflags         client-handcode server-handcode
67         glxopcode        1
68
69
70 RenderLarge()
71         return           void
72         category         glx
73         dlflags          notlistable
74         glxflags         client-handcode server-handcode
75         glxopcode        2
76
77
78 CreateContext(dpy, vis, shareList, direct)
79         return           GLXContext
80         param            dpy            Display in reference
81         param            vis            XVisualInfo in reference
82         param            shareList              GLXContext in value
83         param            direct Bool in value
84         glxflags         client-handcode server-handcode
85         category         glx
86         dlflags          notlistable
87         glxopcode        3
88
89
90 DestroyContext(dpy, context)
91         return           void
92         param            dpy            Display in reference
93         param            context       GLXContext in value
94         glxflags         client-handcode server-handcode
95         category         glx
96         dlflags          notlistable
97         glxopcode        4
98
99
100 MakeCurrent(dpy, drawable, context)
101         return           Bool
102         param            dpy            Display in reference
103         param            drawable       GLXDrawable in value
104         param            context       GLXContext in value
105         glxflags         client-handcode server-handcode
106         category         glx
107         dlflags          notlistable
108         glxopcode        5
109
110
111 GetCurrentContext()
112         return          GLXContext
113         category glx
114
115 IsDirect(dpy, context)
116         return          Bool
117         param           dpy             Display in reference
118         param           context         GLXContext in value
119         glxflags        client-handcode server-handcode
120         category        glx
121         dlflags         notlistable
122         glxopcode       6
123
124
125 QueryVersion(dpy, major, minor)
126         return           Bool
127         param            dpy            Display in reference
128         param            major          Int32 out reference
129         param            minor          Int32 out reference
130         category         glx
131         dlflags          notlistable
132         glxflags         client-handcode server-handcode
133         glxopcode        7
134
135
136 WaitGL()
137         return           void
138         category         glx
139         dlflags          notlistable
140         glxflags         client-handcode server-handcode
141         glxopcode        8
142
143
144 WaitX()
145         return           void
146         category         glx
147         dlflags          notlistable
148         glxflags         client-handcode server-handcode
149         glxopcode        9
150
151
152 CopyContext(dpy, source, dest, mask)
153         return           void
154         param            dpy            Display in reference
155         param            source         GLXContext in value
156         param            dest           GLXContext in value
157         param            mask           ulong in value
158         category         glx
159         dlflags          notlistable
160         glxflags         client-handcode server-handcode
161         glxopcode        10
162
163
164 SwapBuffers(dpy, drawable)
165         return           void
166         param            dpy            Display in reference
167         param            drawable       GLXDrawable in value
168         category         glx
169         dlflags          notlistable
170         glxflags         client-handcode server-handcode
171         glxopcode        11
172
173
174 UseXFont(font, first, count, list_base)
175         return           void
176         param            font           Font in value
177         param            first          Int32 in value
178         param            count          Int32 in value
179         param            list_base      Int32 in value
180         category         glx
181         dlflags          notlistable
182         glxflags         client-handcode server-handcode
183         glxopcode        12
184
185
186 CreateGLXPixmap(dpy, visual, pixmap)
187         return           GLXPixmap
188         param            dpy            Display in reference
189         param            visual         XVisualInfo in reference
190         param            pixmap         Pixmap in value
191         category         glx
192         dlflags          notlistable
193         glxflags         client-handcode server-handcode
194         glxopcode        13
195
196 GetVisualConfigs()
197         return           void
198         category         glx
199         dlflags          notlistable
200         glxflags         client-handcode server-handcode
201         glxopcode        14
202
203
204 DestroyGLXPixmap(dpy, pixmap)
205         return           void
206         param            dpy            Display in reference
207         param            pixmap         GLXPixmap in value
208         glxflags         client-handcode
209         category         glx
210         dlflags          notlistable
211         glxopcode        15
212
213
214 VendorPrivate()
215         return          void
216         glxflags        client-handcode server-handcode
217         category        glx
218         dlflags         notlistable
219         glxopcode       16
220
221
222 VendorPrivateWithReply()
223         return          void
224         glxflags        client-handcode server-handcode
225         category        glx
226         dlflags         notlistable
227         glxopcode       17
228
229 ###############################################################################
230 #
231 # GLX1.1 commands
232 #
233 ###############################################################################
234 QueryExtensionsString(dpy, screen)
235         return          CharPointer
236         param           dpy             Display in reference
237         param           screen          Int32 in value
238         glxflags        client-handcode server-handcode
239         category        glx
240         dlflags         notlistable
241         glxopcode       18
242
243 QueryServerString(dpy, screen, name)
244         return          CharPointer
245         param           dpy             Display in reference
246         param           screen          Int32 in value
247         param           name            Int32 in value
248         glxflags        client-handcode server-handcode
249         category        glx
250         dlflags         notlistable
251         glxopcode       19
252
253 ClientInfo()
254         return          void
255         glxflags        client-handcode server-handcode
256         category        glx
257         dlflags         notlistable
258         glxopcode       20
259
260 ###############################################################################
261 #
262 # GLX1.3 commands
263 #
264 ###############################################################################
265 # defined in glxext.spec
266 #GetFBConfigs()
267 #       return          void
268 #       category        glx
269 #       dlflags         notlistable
270 #       glxflags        client-handcode server-handcode
271 #       glxopcode       21
272
273 # defined in glxext.spec
274 #CreatePixmap(config, pixmap, glxpixmap)
275 #       return          void
276 #       param           config          Int32 in value
277 #       param           pixmap          Int32 in value
278 #       param           glxpixmap       Int32 in value
279 #       dlflags         notlistable
280 #       glxflags        client-handcode server-handcode
281 #       category        glx
282 #       glxopcode       22
283
284 # defined in glxext.spec
285 #DestroyPixmap(glxpixmap)
286 #       return          void
287 #       param           glxpixmap       Int32 in value
288 #       dlflags         notlistable
289 #       glxflags        client-handcode server-handcode
290 #       category        glx
291 #       glxopcode       23
292
293 # defined in glxext.spec
294 #CreateNewContext(config, render_type, share_list, direct)
295 #       return          void
296 #       param           config          Int32 in value
297 #       param           render_type     Int32 in value
298 #       param           share_list      Int32 in value
299 #       param           direct          Int32 in value
300 #       dlflags         notlistable
301 #       glxflags        client-handcode server-handcode
302 #       category        glx
303 #       glxopcode       24
304
305 # defined in glxext.spec
306 #QueryContext()
307 #       return          void
308 #       dlflags         notlistable
309 #       glxflags        client-handcode server-handcode
310 #       category        glx
311 #       glxopcode       25
312
313 # defined in glxext.spec
314 #MakeContextCurrent(drawable, readdrawable, context)
315 #       return          void
316 #       param           drawable        GLXDrawable in value
317 #       param           readdrawable    GLXDrawable in value
318 #       param           context         Int32 in value
319 #       dlflags         notlistable
320 #       glxflags        client-handcode server-handcode
321 #       category        glx
322 #       glxopcode       26
323
324 # defined in glxext.spec
325 #CreatePbuffer(config, pbuffer)
326 #       return          void
327 #       param           config          Int32 in value
328 #       param           pbuffer         Int32 in value
329 #       dlflags         notlistable
330 #       glxflags        client-handcode server-handcode
331 #       category        glx
332 #       glxopcode       27
333
334 # defined in glxext.spec
335 #DestroyPbuffer(pbuffer)
336 #       return          void
337 #       param           pbuffer         Int32 in value
338 #       dlflags         notlistable
339 #       glxflags        client-handcode
340 #       category        glx
341 #       glxopcode       28
342
343 # this func seems dead
344 GetDrawableAttributes(drawable)
345         return          void
346         param           drawable        GLXDrawable in value
347         dlflags         notlistable
348         glxflags        client-handcode server-handcode
349         category        glx
350         glxopcode       29
351
352 # this func seems dead
353 ChangeDrawableAttributes(drawable)
354         return          void
355         param           drawable        GLXDrawable in value
356         dlflags         notlistable
357         glxflags        client-handcode server-handcode
358         category        glx
359         glxopcode       30
360
361 # defined in glxext.spec
362 #CreateWindow(config, window, glxwindow)
363 #       return          void
364 #       param           config          Int32 in value
365 #       param           window          Int32 in value
366 #       param           glxwindow       Int32 in value
367 #       dlflags         notlistable
368 #       glxflags        client-handcode server-handcode
369 #       category        glx
370 #       glxopcode       31
371
372 # defined in glxext.spec
373 #DestroyWindow(glxwindow)
374 #       return          void
375 #       param           glxwindow       Int32 in value
376 #       dlflags         notlistable
377 #       glxflags        client-handcode server-handcode
378 #       category        glx
379 #       glxopcode       32
380
381 ###############################################################################
382 #
383 # EXT_import_context extension commands
384 #
385 ###############################################################################
386 # defined in glxext.spec
387 #QueryContextInfoEXT()
388 #       return           void
389 #       category         glx
390 #       dlflags          notlistable
391 #       glxflags         client-handcode server-handcode
392 #       glxvendorglx     1024
393